13165 Letture

Mozilla: aggiornate i driver delle vostre schede video

Aggiornate i driver della vostra scheda video! E' questa l'esortazione lanciata da Benoit Jacob, uno dei responsabili di Mozilla, che consiglia agli utenti di controllare la versione del driver in uso sul proprio sistema operativo, in particolare nel caso in cui si impieghi Windows. Per poter fruire dell'accelerazione hardware introdotta in Firefox 4.0, gli utenti del browser web opensource dovranno necessariamente adeguare i driver delle proprie schede in modo tale da poter trarre vantaggio dalla potenza di calcolo della GPU.

"Quando abbiamo abilitato di default l'accelerazione hardware", ha spiegato Jacob riferendosi alle prime "nigthly builds" di Firefox 4.0 distribuite dal mese di settembre scorso, "i dati statistici sui crash e le segnalazioni dei bug pervenute dagli utenti hanno evidenziato come, in molti casi, versi datate dei driver video causavano comportamenti anomali". Jacob ha aggiunto che i tecnici di Mozilla hanno preferito trattare il problema disattivando in modo selettivo l'accelerazione "GPU-based" su quei sistemi che montano driver inadeguati.
Per prevenire eventuali crash, quindi, Mozilla ha stilato una sorta di "lista nera": se il driver video usato dall'utente è nell'elenco, l'accelerazione hardware viene disattivata.


Diversamente da Internet Explorer 9.0, che non è compatibile con Windows XP, Firefox 4.0 supporta - almeno in modo parziale - l'accelerazione hardware anche su tale sistema operativo. La scelta è senza dubbio ottimale dal momento che Windows XP resta tutt'oggi il sistema operativo più diffuso a livello mondiale (55%, con Windows 7 che segue, al secondo posto, con il 23%). Il supporto dell'accelerazione hardware su Windows XP viene reso possibile grazie all'utilizzo delle API Direct3D piuttosto che sulle librerie più recenti integrate soltanto su Windows Vista e Windows 7.

Jacob ha puntualizzato che gli utenti Windows debbono accertarsi di impiegare "un driver video molto recente" nel caso di schede grafiche basate su chipset Intel. Per quanto concerne le schede NVidia, è obbligatorio possedere un driver aggiornato alla versione 257.21 o successive; nel caso di AMD ATI alla versione 10.6 o seguenti.


Gli utenti di Mac OS X debbono invece possedere almeno la versione 10.6.3 del sistema operativo di Apple per poter sfruttare tutte le nuove caratteristiche del browser di casa Mozilla. Alcune schede grafiche che equipaggiano i Mac più "datati" non sono in grado di supportare OpenGL: in tali situazioni non si potrà godere delle nuove "feature" introdotte con il lancio della quarta versione di Firefox (tra i sistemi esclusi ci sono, ad esempio, i Mac Mini di metà 2007 oltre alle schede grafiche ATI Radeon X1000 e precedenti, Nvidia GeForce FX e precedenti, Intel GMA 950 e precedenti).

Maggiori informazioni sui requisiti minimi per l'utilizzo dell'accelerazione hardware in Firefox 4.0 sono disponibili facendo riferimento a questa pagina. La versione finale di Firefox 4.0 dovrebbe arrivare entro la fine del mese di marzo.

  1. Avatar
    belcucciolo
    23/03/2011 23:11:33
    io so il motivo del crasch è il plugin adobe flash player alcune versioni problemi di incompatibilita testato e ti confermo me lo fa anke cn alcuni browser ie9 google crhome e mozzila causa problematica sdoppiamento delle parole su alcuni siti tipo facebook :D sono da tre setimane che faccio test sopratutto su schede video :D
Mozilla: aggiornate i driver delle vostre schede video - IlSoftware.it