5216 Letture

Una nuova vulnerabilità interessa Flash, Reader ed Acrobat

C'è una nuova pericolosa vulnerabilità in Flash Player. Lo hanno confermato i tecnici di Adobe che promettono il rilascio di un aggiornamento risolutivo nel giro di due settimane. Anche Reader ed Acrobat sono affetti dalla medesima falla di sicurezza dal momento che entrambi i prodotti sono in grado di visualizzare e "riprodurre" contenuti Flash eventualmente presenti all'interno di documenti in formato PDF.
Secondo Adobe la "lacuna" sarebbe già stata presa di mira e sfruttata per sferrare diversi attacchi in Rete. Per il momento, però, non si sono rilevati attacchi nei confronti di Flash Player mentre le aggressioni si sarebbero concentrate su Reader ed Acrobat, attraverso la diffusione di file PDF "maligni".

Secondo il ricercatore Mila Parkour, che per primo ha scoperto la nuova vulnerabilità analizzando alcuni documenti PDF reperiti in Rete, un malintenzionato può riuscire ad eseguire malware sul sistema dell'utente semplicemente inducendo quest'ultimo ad aprire un documento modificato "ad arte" con una qualunque versione di Adobe Reader o di Adobe Acrobat.
Adobe ha confermato che affette dal problema sarebbero le versioni di Flash Player per tutti i sistemi operativi (Windows, Mac, Linux ed Android).


Come consiglio a beneficio degli utenti di Reader e di Acrobat, gli esperti suggeriscono la valutazione di software alternativi (Foxit Reader, ad esempio, non risulta affetto dalla medesima vulnerabilità) oppure di disattivare temporaneamente il supporto della tecnologia Flash all'interno dei file PDF.
Il "workaround" suggerito dagli stessi tecnici di Adobe consiste nella ridenominazione o nell'eliminazione del file authplay.dll (sui sistemi Windows; AuthPlayLib.bundle sui Mac e libauthplay.so.0.0.0 sulle macchine Unix-based). Effettuata quest'operazione, qualora si dovesse aprire un documento PDF contenente elementi realizzati in Flash, Reader od Acrobat andranno in crash ma si eviterà l'esecuzione di codice dannoso.

  1. Avatar
    gtdt2004
    03/11/2010 14:28:09
    sarebbe stato meglio mettere in rete un programma correttivo invece di demandare all'utente la correzione
Una nuova vulnerabilità interessa Flash, Reader ed Acrobat - IlSoftware.it