1388 Letture

Vulnerabilità di sicurezza in Acrobat Reader per Linux

Adobe sta mettendo in allerta i propri utenti circa una grossa vulnerabilità di sicurezza che interessa una delle più diffuse ed apprezzate applicazioni: Acrobat Reader. La falla, appena scoperta, permetterebbe ad un malintenzionato di accedere al sistema creando un file PDF "maligno", opportunamente concepito per far danni ed invitando il malcapitato ad aprirlo. Il file PDF potrebbe essere inserito in una normale pagina web o spedito alla "vittima" via e-mail.
La vulnerabilità di Acrobat Reader non interessa le versioni Windows del programma ma solo quelle destinate a sistemi Linux e Solaris e, in particolare, la versione 5.x - ampiamente adottata in tutto il mondo -.
Il bug risiede nella funzione UnixAppOpenFilePerform(), invocata da Acrobat Reader allorquando venga aperto un certo tipo di documento. Se sfruttata, la vulnerabilità può innescare un errore di buffer overflow con la conseguente possibilità, per un malintenzionato, di eseguire codice nocivo.
Adobe raccomanda di aggiornare Acrobat Reader alla versione 7.0 che non è interessata dal problema di sicurezza.

Vulnerabilità di sicurezza in Acrobat Reader per Linux - IlSoftware.it