32995 Letture

Vulnerabilità javascript mette a rischio i server HTTP?

Nei giorni scorsi è stata scoperta una vulnerabilità presente nei più diffusi browser Internet che supportano il codice javascript (praticamente tutti!), che consentirebbe di rendere visibili i contenuti dei pc collegati in Rete a hacker e malintenzionati via Internet.
Il bug è stato scoperto da Adama Megacz e permetterebbe ad un malintenzionato di utilizzare qualunque browser mediante il quale sia possibile eseguire codice javascript per interagire (mediante HTTP GET e HTTP POST) con qualsiasi server HTTP, anche se questo sia protetto da firewall.
Megacz afferma di aver avvertito i produttori dei vari browser più di trenta giorni fa e sottolinea come ancora non sia uscita alcuna patch.
Per maggiori informazioni fate riferimento a questi appunti su SecurityFocus.

Vulnerabilità javascript mette a rischio i server HTTP? - IlSoftware.it