Problema con utf 8

Il luogo giusto per le vostre discussioni su qualunque software di grafica e sulle tematiche riguardanti l'editing audio/video. Si parla di DirectX, editing audio/video, codec e computer grafica.

Moderatore: Staff forum IlSoftware.it

Ildebrando
Junior Software
Junior Software
Messaggi: 102
Iscritto il: 24 dic 2007 12:55
Contatta:

Problema con utf 8

Messaggioda Ildebrando » 21 ott 2011 14:04

Salve,
ho un problema con la codifica dei caratteri in Dreamweaver: in pratica, nonostante abbia impostato il charset in UTF-8 in tutte le pagine web e nelle impostazioni del programma, mi continua a ricodificare i caratteri nel tag title e description quando li inserisco attraverso la casella apposita nella barra delle proprietà, mentre non lo fa nel testo dove inserisce tranquillamente tutte le lettere accentate nonché i caratteri speciali.
Andando nelle impostazioni del programma in modifica > preferenze > nuovo documento > codifica predefinita… è impostato in Unicode (UTF-8) e la casella sotto che dice di usare questa codifica per i documenti che non lo specificano è spuntata.
Il doctype e l’head della pagina html è impostata così:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="it" lang="it">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Il tuo pap&agrave;</title>

E’ un bug del programma o qualcuno sa come risolvere?
E se lascio il titolo così, può dare problemi? I motori di ricerca come lo vedono poi?
Grazie