Sconti Amazon
lunedì 22 marzo 2021 di 14024 Letture
Come visualizzare tutte le formule Excel

Come visualizzare tutte le formule Excel

Come leggere le formule Excel presenti nel foglio elettronico e trasformarle in una serie di stringhe di testo.

I fogli elettronici più complessi possono essere davvero stracolmi di formule. Capire come i dati vengono gestiti ed elaborati potrebbe quindi non risultare cosa immediata.

Presentiamo una semplice procedura che permette di estrarre tutte le formule Excel e visualizzarle sotto forma di testo senza dover selezionare ogni cella e controllare il contenuto del campo Formula sotto la barra dei menu.

Digitando =TESTO.FORMULA() in una cella vuota del foglio elettronico quindi indicando tra parentesi tonde la casella di riferimento (contenente una formula), la si potrà leggere in tutta comodità.

Come visualizzare tutte le formule Excel

Impostando la formula come segue, si può fare in modo che Excel mostri il testo della formula solo quando effettivamente presente nella cella indicata:
=SE(VAL.FORMULA(A2);TESTO.FORMULA(A2);"")

Al posto di A2 va ovviamente sostituito il riferimento di cella corretto.

Può capitare infatti che una cella del foglio di calcolo non contenga alcuna formula, sia vuota oppure ospiti una semplice stringa di testo. Utilizzando la formula presentata, la cella in cui ci si trova rimarrà vuota e non mostrerà alcun messaggio d'errore.

Come visualizzare tutte le formule Excel

Trascinando la formula appena aggiunta agendo sull'angolo inferiore destro sarà possibile leggere automaticamente il contenuto delle formule Excel presenti nelle celle immediatamente sottostanti.

Come visualizzare tutte le formule Excel

Lo stesso approccio è utilizzabile con le versioni tradizionali di Office, con quelle basate sul cloud (Microsoft 365) così come con Excel Online.


I più scaricati del mese

Buoni regalo Amazon
Come visualizzare tutte le formule Excel - IlSoftware.it